What’s Vulnerable › Vulnerabilities
CVE-2025-11143
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-05 · updated 2026-06-17
- Weakness: CWE-20
Description
The Jetty URI parser has some key differences to other common parsers when evaluating invalid or unusual URIs. Differential parsing of URIs in systems using multiple components may result in security by-pass. For example a component that enforces a black list may interpret the URIs differently from one that generates a response. At the very least, differential parsing may divulge implementation details.
Affected products
- The Eclipse Foundation Eclipse Jetty: from 9.4.0 through 9.4.58; from 10.0.0 through 10.0.26; from 11.0.0 through 11.0.26; from 12.0.0 before 12.0.31; from 12.1.0 before 12.1.5 — fixed in 12.0.31, 12.1.5
How to fix
Upgrade to a fixed version: The Eclipse Foundation Eclipse Jetty 12.0.31, 12.1.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-11143 or the next vulnerability affects your stack