What’s Vulnerable › Vulnerabilities
CVE-2025-11158: Hitachi Vantara Pentaho Data Integration & Analytics - Missing Authorization
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-10 · updated 2026-06-17
- Weakness: CWE-862
Description
Hitachi Vantara Pentaho Data Integration & Analytics versions before 10.2.0.6, including 9.3.x and 8.3.x, do not restrict Groovy scripts in new PRPT reports published by users, allowing insertion of arbitrary scripts and leading to a RCE.
Affected products
- Hitachi Vantara Pentaho Data Integration and Analytics: before 10.2.0.6 — fixed in 10.2.0.6
How to fix
Upgrade to a fixed version: Hitachi Vantara Pentaho Data Integration and Analytics 10.2.0.6. Check the vendor advisory for mitigations.
References
- https://support.pentaho.com/hc/en-us/articles/39975058295821--Resolved-Hitachi-Vantara-Pentaho-Data-Integration-Analytics-Missing-Authorization-Versions-before-10-2-0-6-impacted-CVE-2025-11158
- https://www.ox.security/blog/cve-2025-11158/
Get alerted when CVE-2025-11158 or the next vulnerability affects your stack