What’s Vulnerable › Vulnerabilities
CVE-2025-11160: WPBakery Page Builder <= 8.6.1 - Stored Cross-Site Scripting via Custom JS Module
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-15 · updated 2026-10-08
- Weakness: CWE-80
Description
The WPBakery Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Custom JS module in all versions up to, and including, 8.6.1. This is due to insufficient input sanitization and output escaping of user-supplied JavaScript code in the Custom JS module. This makes it possible for authenticated attackers with contributor-level access or higher to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page via the WPBakery Page Builder Custom JS module granted they have access to the WPBakery editor for post types.
Affected products
- WPBakery Page Builder: before 8.7 — fixed in 8.7
How to fix
Upgrade to a fixed version: WPBakery Page Builder 8.7. Check the vendor advisory for mitigations.
References
- https://kb.wpbakery.com/docs/preface/release-notes/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4c42cc4e-34e7-4f14-b850-7ba5dd2ae099?source=cve
Get alerted when CVE-2025-11160 or the next vulnerability affects your stack