What’s Vulnerable › Vulnerabilities
CVE-2025-11165
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-24 · updated 2026-06-17
- Weakness: CWE-89
Description
A sandbox escape vulnerability exists in dotCMS’s Velocity scripting engine (VTools) that allows authenticated users with scripting privileges to bypass class and package restrictions enforced by SecureUberspectorImpl. By dynamically modifying the Velocity engine’s runtime configuration and reinitializing its Uberspect, a malicious actor can remove the introspector.restrict.classes and introspector.restrict.packages protections. Once these restrictions are cleared, the attacker can access arbitrary Java classes, including java.lang.Runtime, and execute arbitrary system commands under the privileges of the application process (e.g. dotCMS or Tomcat user).
Affected products
- dotCMS core: before 24.12.27; from 25.01.07 before 25.07.10 — fixed in 24.12.27, 25.07.10
How to fix
Upgrade to a fixed version: dotCMS core 24.12.27, 25.07.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-11165 or the next vulnerability affects your stack