What’s Vulnerable › Vulnerabilities
CVE-2025-11183: Cross-Site Scripting Vulnerability in QWC2
- Severity: medium (CVSS 6.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-13 · updated 2026-10-23
- Weakness: CWE-79
Description
Cross-Site Scripting vulnerability in attribute table in QGIS QWC2 <2025.08.14 allows an authorized attacker to plant arbitrary JavaScript code in the page
Affected products
- QGIS QWC2: before 2025.08.14 — fixed in 2025.08.14
How to fix
Upgrade to a fixed version: QGIS QWC2 2025.08.14. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-11183 or the next vulnerability affects your stack