What’s Vulnerable › Vulnerabilities
CVE-2025-11224: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-14 · updated 2026-06-17
- Weakness: CWE-79
Description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 15.10 before 18.3.6, 18.4 before 18.4.4, and 18.5 before 18.5.2 that could have allowed an authenticated user to execute stored cross-site scripting through improper input validation in the Kubernetes proxy functionality.
Affected products
- GitLab: from 15.10.0 before 18.3.6; from 18.4.0 before 18.4.4; from 18.5.0 before 18.5.2 — fixed in 18.3.6, 18.4.4, 18.5.2
How to fix
Upgrade to a fixed version: GitLab 18.3.6, 18.4.4, 18.5.2. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/releases/2025/11/12/patch-release-gitlab-18-5-2-released/
- https://gitlab.com/gitlab-org/gitlab/-/issues/573223
- https://hackerone.com/reports/3277291
Get alerted when CVE-2025-11224 or the next vulnerability affects your stack