What’s Vulnerable › Vulnerabilities
CVE-2025-11233: Rust standard library didn't detect all path separators on Cygwin
- Severity: medium (CVSS 6.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-01 · updated 2026-10-09
- Weakness: CWE-22
Description
Starting from Rust 1.87.0 and before Rust 1.89.0, the tier 3 Cygwin target (`x86_64-pc-cygwin`) didn't correctly handle path separators, causing the standard library's Path API to ignore path components separated by backslashes. Due to this, programs compiled for Cygwin that validate paths could misbehave, potentially allowing path traversal attacks or malicious filesystem operations. Rust 1.89.0 fixes the issue by handling both Win32 and Unix style paths in the standard library for the Cygwin target. While we assess the severity of this vulnerability as "medium", please note that the tier 3 Cygwin compilation target is only available when building it from source: no pre-built binaries are distributed by the Rust project, and it cannot be installed through Rustup. Unless you manually compiled the `x86_64-pc-cygwin` target you are not affected by this vulnerability. Users of the tier 1 MinGW target (`x86_64-pc-windows-gnu`) are also explicitly not affected.
Affected products
- Rust Project std: from 1.87.0 before 1.89.0 — fixed in 1.89.0
How to fix
Upgrade to a fixed version: Rust Project std 1.89.0. Check the vendor advisory for mitigations.
References
- https://github.com/rust-lang/rust/pull/141864
- https://groups.google.com/g/rustlang-security-announcements/c/oT9zCvLLYkw
Get alerted when CVE-2025-11233 or the next vulnerability affects your stack