What’s Vulnerable › Vulnerabilities
CVE-2025-11340: Incorrect Authorization in GitLab
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-09 · updated 2026-10-19
- Weakness: CWE-863
Description
GitLab has remediated an issue in GitLab EE affecting all versions from 18.3 to 18.3.4, 18.4 to 18.4.2 that, under certain conditions, could have allowed authenticated users with read-only API tokens to perform unauthorized write operations on vulnerability records by exploiting incorrectly scoped GraphQL mutations.
Affected products
- GitLab: from 18.3.0 before 18.3.4; from 18.4.0 before 18.4.2 — fixed in 18.3.4, 18.4.2
How to fix
Upgrade to a fixed version: GitLab 18.3.4, 18.4.2. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/releases/2025/10/08/patch-release-gitlab-18-4-2-released/
- https://gitlab.com/gitlab-org/gitlab/-/issues/567847
Get alerted when CVE-2025-11340 or the next vulnerability affects your stack