What’s Vulnerable › Vulnerabilities
CVE-2025-11529: ChurchCRM API Endpoint AuthMiddleware.php AuthMiddleware missing authentication
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-10-09 · updated 2026-10-19
- Weakness: CWE-287
Description
A security flaw has been discovered in ChurchCRM up to 5.18.0. This impacts the function AuthMiddleware of the file src/ChurchCRM/Slim/Middleware/AuthMiddleware.php of the component API Endpoint. The manipulation results in missing authentication. The attack can be executed remotely. The exploit has been released to the public and may be used for attacks. The patch is identified as 3a1cffd2aea63d884025949cfbcfd274d06216a4. A patch should be applied to remediate this issue.
Affected products
- ChurchCRM CRM: before 5.19.0 — fixed in 5.19.0
How to fix
Upgrade to a fixed version: ChurchCRM CRM 5.19.0. Check the vendor advisory for mitigations.
References
- https://github.com/ChurchCRM/CRM/commit/3a1cffd2aea63d884025949cfbcfd274d06216a4
- https://github.com/ChurchCRM/CRM/pull/7376
- https://github.com/uartu0/advisories/blob/main/churchcrm-api-auth-bypass-2025.md
- https://vuldb.com/?ctiid.327667
- https://vuldb.com/?id.327667
- https://vuldb.com/?submit.669916
- https://github.com/uartu0/advisories/blob/main/churchcrm-api-auth-bypass-2025.md
Get alerted when CVE-2025-11529 or the next vulnerability affects your stack