What’s Vulnerable › Vulnerabilities
CVE-2025-11573: Denial of Service issue in Amazon.IonDotnet
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-09 · updated 2026-10-23
- Weakness: CWE-1286
Description
An infinite loop issue in Amazon.IonDotnet library versions <v1.3.2 may allow a threat actor to cause a denial of service through a specially crafted text input. To mitigate this issue, users should upgrade to version v1.3.2. As of August 20, 2025, this library has been deprecated and will not receive further updates.
Affected products
- Amazon.IonDotnet: before 1.3.2 — fixed in 1.3.2
How to fix
Upgrade to a fixed version: Amazon.IonDotnet 1.3.2. Check the vendor advisory for mitigations.
References
- https://aws.amazon.com/security/security-bulletins/AWS-2025-022/
- https://github.com/amazon-ion/ion-dotnet/releases/tag/v1.3.2
- https://github.com/amazon-ion/ion-dotnet/security/advisories/GHSA-q5r6-9qwq-g2wj
Get alerted when CVE-2025-11573 or the next vulnerability affects your stack