What’s Vulnerable › Vulnerabilities
CVE-2025-11578: Pre-Receive Hook Path Collision Vulnerability in GitHub Enterprise Server Allowing Privilege Escalation
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-10 · updated 2026-10-07
- Weakness: CWE-59
Description
A privilege escalation vulnerability was identified in GitHub Enterprise Server that allowed an authenticated Enterprise admin to gain root SSH access to the appliance by exploiting a symlink escape in pre-receive hook environments. By crafting a malicious repository and environment, an attacker could replace system binaries during hook cleanup and execute a payload that adds their own SSH key to the root user’s authorized keys—thereby granting themselves root SSH access to the server. To exploit this vulnerability, the attacker needed to have enterprise admin privileges. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.19, and was fixed in versions 3.14.20, 3.15.15, 3.16.11, 3.17.8, 3.18.2. This vulnerability was reported via the GitHub Bug Bounty program.
Affected products
- GitHub Enterprise Server: from 3.14.0 before 3.14.20; from 3.15.0 before 3.15.15; from 3.16.0 before 3.16.11; from 3.17.0 before 3.17.8; from 3.18.0 before 3.18.2 — fixed in 3.14.20, 3.15.15, 3.16.11, 3.17.8, 3.18.2
How to fix
Upgrade to a fixed version: GitHub Enterprise Server 3.14.20, 3.15.15, 3.16.11, 3.17.8. Check the vendor advisory for mitigations.
References
- https://docs.github.com/en/enterprise-server@3.14/admin/release-notes#3.14.20
- https://docs.github.com/en/enterprise-server@3.15/admin/release-notes#3.15.15
- https://docs.github.com/en/enterprise-server@3.16/admin/release-notes#3.16.11
- https://docs.github.com/en/enterprise-server@3.17/admin/release-notes#3.17.8
- https://docs.github.com/en/enterprise-server@3.18/admin/release-notes#3.18.2
Get alerted when CVE-2025-11578 or the next vulnerability affects your stack