What’s Vulnerable › Vulnerabilities
CVE-2025-11619
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-15 · updated 2026-10-08
- Weakness: CWE-295
Description
Improper certificate validation when connecting to gateways in Devolutions Server 2025.3.2 and earlier allows attackers in MitM position to intercept traffic.
Affected products
- Devolutions Server: before 2025.2.15.0; from 2025.3.2.0 before 2025.3.3.0 — fixed in 2025.2.15.0, 2025.3.3.0
How to fix
Upgrade to a fixed version: Devolutions Server 2025.2.15.0, 2025.3.3.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-11619 or the next vulnerability affects your stack