What’s Vulnerable › Vulnerabilities
CVE-2025-11695: Configuration may unexpectedly disable certificate validation
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-13 · updated 2026-10-08
- Weakness: CWE-295
Description
When tlsInsecure=False appears in a connection string, certificate validation is disabled. This vulnerability affects MongoDB Rust Driver versions prior to v3.2.5
Affected products
- MongoDB Rust Driver: before 3.2.5 — fixed in 3.2.5
How to fix
Upgrade to a fixed version: MongoDB Rust Driver 3.2.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-11695 or the next vulnerability affects your stack