What’s Vulnerable › Vulnerabilities
CVE-2025-11699: CVE-2025-11699
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-01 · updated 2026-10-18
- Weakness: CWE-613
Description
nopCommerce v4.70 and prior, and version 4.80.3, does not invalidate session cookies after logout or session termination, allowing an attacker who has a a valid session cookie access to privileged endpoints (such as /admin) even after the legitimate user has logged out, enabling session hijacking. Any version above 4.70 that is not 4.80.3 fixes the vulnerability.
Affected products
- nopSolutions nopCommerce: before 4.70.0; 4.80.3 — fixed in 4.70.0
How to fix
Upgrade to a fixed version: nopSolutions nopCommerce 4.70.0. Check the vendor advisory for mitigations.
References
- https://github.com/nopSolutions/nopCommerce/issues/7044
- https://seclists.org/fulldisclosure/2025/Aug/14
- https://www.nopcommerce.com/en/release-notes?srsltid=AfmBOoravPKjN19pm_XZbXZ7GvPhkt8cxlK6794BJRZlY5RxJU_yNoTT
- https://www.kb.cert.org/vuls/id/633103
Get alerted when CVE-2025-11699 or the next vulnerability affects your stack