What’s Vulnerable › Vulnerabilities

CVE-2025-11702: Missing Authorization in GitLab

Description

GitLab has remediated an issue in EE affecting all versions from 17.1 before 18.3.5, 18.4 before 18.4.3, and 18.5 before 18.5.1 that could have allowed an authenticated attacker with specific permissions to hijack project runners from other projects.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.3.5, 18.4.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-11702 or the next vulnerability affects your stack