What’s Vulnerable › Vulnerabilities
CVE-2025-11710: Cross-process information leaked due to malicious IPC messages
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-14 · updated 2026-10-23
- Weakness: CWE-200
Description
A compromised web process using malicious IPC messages could have caused the privileged browser process to reveal blocks of its memory to the compromised process. This vulnerability was fixed in Firefox 144, Firefox ESR 115.29, Firefox ESR 140.4, Thunderbird 144, and Thunderbird 140.4.
Affected products
- Mozilla Firefox: before 115.29.0; before 144.0; from 116.0 before 140.4.0 — fixed in 115.29.0, 140.4.0, 144.0
- Mozilla Thunderbird: before 140.4.0; from 141.0 before 144.0 — fixed in 140.4.0, 144.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 115.29.0, 140.4.0, 144.0; Mozilla Thunderbird 140.4.0, 144.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1989899
- https://www.mozilla.org/security/advisories/mfsa2025-81/
- https://www.mozilla.org/security/advisories/mfsa2025-82/
- https://www.mozilla.org/security/advisories/mfsa2025-83/
- https://www.mozilla.org/security/advisories/mfsa2025-84/
- https://www.mozilla.org/security/advisories/mfsa2025-85/
- https://lists.debian.org/debian-lts-announce/2025/10/msg00015.html
- https://lists.debian.org/debian-lts-announce/2025/10/msg00031.html
Get alerted when CVE-2025-11710 or the next vulnerability affects your stack