What’s Vulnerable › Vulnerabilities
CVE-2025-11814: Ultimate Addons for WPBakery Page Builder < 3.21.1 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-16 · updated 2026-10-08
- Weakness: CWE-79
Description
The Ultimate Addons for WPBakery plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to 3.21.1 (exclusive) due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Brainstorm Force Ultimate Addons for WPBakery: before 3.21.1 — fixed in 3.21.1
How to fix
Upgrade to a fixed version: Brainstorm Force Ultimate Addons for WPBakery 3.21.1. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/wordpress/plugin/ultimate_vc_addons/vulnerability/wordpress-ultimate-addons-for-wpbakery-page-builder-plugin-3-21-1-cross-site-scripting-xss-vulnerability
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1f41101c-c54f-4e97-a0fb-79a17d5f0929?source=cve
Get alerted when CVE-2025-11814 or the next vulnerability affects your stack