What’s Vulnerable › Vulnerabilities

CVE-2025-11865: Incorrect Authorization in GitLab

Description

An issue has been discovered in GitLab EE affecting all versions from 18.1 before 18.3.6, 18.4 before 18.4.4, and 18.5 before 18.5.2 that, under certain circumstances, could have allowed an attacker to remove Duo flows of another user.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.3.6, 18.4.4, 18.5.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-11865 or the next vulnerability affects your stack