What’s Vulnerable › Vulnerabilities

CVE-2025-11892: DOM-based Cross-Site Scripting was identified in GitHub Enterprise Server Issues search allows privilege escalation and unauthorized workflow triggers

Description

An improper neutralization of input vulnerability was identified in GitHub Enterprise Server that allows DOM-based cross-site scripting via Issues search label filter that could lead to privilege escalation and unauthorized workflow triggers. Successful exploitation requires an attacker to have access to the target GitHub Enterprise Server instance and to entice a user, while operating in sudo mode, to click on a crafted malicious link to perform actions that require elevated privileges. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.18.1, 3.17.7, 3.16.10, 3.15.14, 3.14.19.

Affected products

How to fix

Upgrade to a fixed version: GitHub Enterprise Server 3.14.19, 3.15.14, 3.16.10, 3.17.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-11892 or the next vulnerability affects your stack