What’s Vulnerable › Vulnerabilities

CVE-2025-11933: DoS Vulnerability in wolfSSL TLS 1.3 CKS Extension

Description

Improper Input Validation in the TLS 1.3 CKS extension parsing in wolfSSL 5.8.2 and earlier on multiple platforms allows a remote unauthenticated attacker to potentially cause a denial-of-service via a crafted ClientHello message with duplicate CKS extensions.

Affected products

How to fix

Upgrade to a fixed version: wolfSSL 5.8.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-11933 or the next vulnerability affects your stack