What’s Vulnerable › Vulnerabilities
CVE-2025-11935: Forward Secrecy Violation in WolfSSL TLS 1.3
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-21 · updated 2026-10-19
- Weakness: CWE-326
Description
With TLS 1.3 pre-shared key (PSK) a malicious or faulty server could ignore the request for PFS (perfect forward secrecy) and the client would continue on with the connection using PSK without PFS. This happened when a server responded to a ClientHello containing psk_dhe_ke without a key_share extension. The re-use of an authenticated PSK connection that on the clients side unexpectedly did not have PFS, reduces the security of the connection.
Affected products
- wolfSSL: from 5.8.2 before 5.8.4 — fixed in 5.8.4
How to fix
Upgrade to a fixed version: wolfSSL 5.8.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-11935 or the next vulnerability affects your stack