What’s Vulnerable › Vulnerabilities
CVE-2025-11964: OOBW in utf_16le_to_utf_8_truncated() in libpcap
- Severity: low (CVSS 1.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-31 · updated 2026-06-17
- Weakness: CWE-787
Description
On Windows only, if libpcap needs to convert a Windows error message to UTF-8 and the message includes characters that UTF-8 represents using 4 bytes, utf_16le_to_utf_8_truncated() can write data beyond the end of the provided buffer.
Affected products
- The Tcpdump Group libpcap: from 1.10.0 before 1.10.6 — fixed in 1.10.6
How to fix
Upgrade to a fixed version: The Tcpdump Group libpcap 1.10.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-11964 or the next vulnerability affects your stack