What’s Vulnerable › Vulnerabilities

CVE-2025-11971: Incorrect Authorization in GitLab

Description

GitLab has remediated an issue in GitLab EE affecting all versions from 10.6 before 18.3.5, 18.4 before 18.4.3, and 18.5 before 18.5.1 that could have allowed an authenticated attacker to trigger unauthorized pipeline executions by manipulating commits.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.3.5, 18.4.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-11971 or the next vulnerability affects your stack