What’s Vulnerable › Vulnerabilities
CVE-2025-11979: Use-after-free in the MongoDB server query planner may lead to crash or undefined behavior
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-20 · updated 2026-10-08
- Weakness: CWE-416
Description
An authorized user may crash the MongoDB server by causing buffer over-read. This can be done by issuing a DDL operation while queries are being issued, under some conditions. This issue affects MongoDB Server v7.0 versions prior to 7.0.25, MongoDB Server v8.0 versions prior to 8.0.15, and MongoDB Server version 8.2.0.
Affected products
- MongoDB: from 7.0.0 before 7.0.25; from 8.0.0 before 8.0.15 — fixed in 7.0.25, 8.0.15
How to fix
Upgrade to a fixed version: MongoDB 7.0.25, 8.0.15. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-11979 or the next vulnerability affects your stack