What’s Vulnerable › Vulnerabilities
CVE-2025-1198: Insufficient Session Expiration in GitLab
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-13 · updated 2026-06-17
- Weakness: CWE-613
Description
An issue discovered in GitLab CE/EE affecting all versions from 16.11 prior to 17.6.5, 17.7 prior to 17.7.4, and 17.8 prior to 17.8.2 meant that long-lived connections in ActionCable potentially allowed revoked Personal Access Tokens access to streaming results.
Affected products
- GitLab: from 16.11.0 before 17.6.5; from 17.7.0 before 17.7.4; from 17.8.0 before 17.8.2 — fixed in 17.6.5, 17.7.4, 17.8.2
How to fix
Upgrade to a fixed version: GitLab 17.6.5, 17.7.4, 17.8.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-1198 or the next vulnerability affects your stack