What’s Vulnerable › Vulnerabilities
CVE-2025-12004: The compare API module breaks Extension:Lockdown
- Severity: critical (CVSS 10.0 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-21 · updated 2026-10-18
- Weakness: CWE-732
Description
Incorrect Permission Assignment for Critical Resource vulnerability in The Wikimedia Foundation Mediawiki - Lockdown Extension allows Privilege Abuse. Fixed in Mediawiki Core Action APIThis issue affects Mediawiki - Lockdown Extension: from master before 1.42.
Affected products
- The Wikimedia Foundation Mediawiki - Lockdown Extension: from master before 1.42 — fixed in 1.42
How to fix
Upgrade to a fixed version: The Wikimedia Foundation Mediawiki - Lockdown Extension 1.42. Check the vendor advisory for mitigations.
References
- https://gerrit.wikimedia.org/r/q/Id275382743957004fa7fc56318fc104d8e2d267b
- https://phabricator.wikimedia.org/T397521
- https://phabricator.wikimedia.org/T397521
Get alerted when CVE-2025-12004 or the next vulnerability affects your stack