What’s Vulnerable › Vulnerabilities

CVE-2025-12029: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 15.11 before 18.4.6, 18.5 before 18.5.4, and 18.6 before 18.6.2 that could have, under certain circumstances, allowed an unauthenticated user to perform unauthorized actions on behalf of another user by injecting malicious external scripts into the Swagger UI."

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.4.6, 18.5.4, 18.6.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-12029 or the next vulnerability affects your stack