What’s Vulnerable › Vulnerabilities
CVE-2025-12044: Vault Vulnerable to Denial of Service Due to Rate Limit Regression
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-23 · updated 2026-10-18
- Weakness: CWE-770
Description
Vault and Vault Enterprise (“Vault”) are vulnerable to an unauthenticated denial of service when processing JSON payloads. This occurs due to a regression from a previous fix for [+HCSEC-2025-24+|https://discuss.hashicorp.com/t/hcsec-2025-24-vault-denial-of-service-though-complex-json-payloads/76393] which allowed for processing JSON payloads before applying rate limits. This vulnerability, CVE-2025-12044, is fixed in Vault Community Edition 1.21.0 and Vault Enterprise 1.16.27, 1.19.11, 1.20.5, and 1.21.0.
Affected products
- HashiCorp Vault: from 1.16.25 before 1.16.27; from 1.18.14 through 1.18.15; from 1.19.9 through 1.19.11; from 1.20.3 before 1.20.5; from 1.20.3 before 1.21.0 — fixed in 1.16.27, 1.20.5, 1.21.0
How to fix
Upgrade to a fixed version: HashiCorp Vault 1.16.27, 1.20.5, 1.21.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-12044 or the next vulnerability affects your stack