What’s Vulnerable › Vulnerabilities
CVE-2025-12057: WavePlayer < 3.8.0 - Unauthenticated Arbitrary File Upload
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-19 · updated 2026-10-19
- Weakness: CWE-434
Description
The WavePlayer WordPress plugin before 3.8.0 does not have authorization in an AJAX action as well as does not validate the file to be copied locally, allowing unauthenticated users to upload arbitrary file on the server and lead to RCE
Affected products
- WavePlayer: before 3.8.0 — fixed in 3.8.0
How to fix
Upgrade to a fixed version: WavePlayer 3.8.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-12057 or the next vulnerability affects your stack