What’s Vulnerable › Vulnerabilities
CVE-2025-12105: Libsoup: heap use-after-free in libsoup message queue handling during http/2 read completion
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-23 · updated 2026-10-18
- Weakness: CWE-416
Description
A flaw was found in the asynchronous message queue handling of the libsoup library, widely used by GNOME and WebKit-based applications to manage HTTP/2 communications. When network operations are aborted at specific timing intervals, an internal message queue item may be freed twice due to missing state synchronization. This leads to a use-after-free memory access, potentially crashing the affected application. Attackers could exploit this behavior remotely by triggering specific HTTP/2 read and cancel sequences, resulting in a denial-of-service condition.
Affected products
- GNOME libsoup: through 3.6.5
- Red Hat Enterprise Linux 10: all versions — fixed in 0:3.6.5-3.el10_1.7
- Red Hat Enterprise Linux 10.0 Extended Update Support: all versions — fixed in 0:3.6.5-3.el10_0.10
How to fix
Upgrade to a fixed version: Red Hat Enterprise Linux 10 0:3.6.5-3.el10_1.7; Red Hat Enterprise Linux 10.0 Extended Update Support 0:3.6.5-3.el10_0.10. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2025:23139
- https://access.redhat.com/errata/RHSA-2025:23437
- https://access.redhat.com/security/cve/CVE-2025-12105
- https://bugzilla.redhat.com/show_bug.cgi?id=2405992
- https://gitlab.gnome.org/GNOME/libsoup/-/merge_requests/481
Get alerted when CVE-2025-12105 or the next vulnerability affects your stack