What’s Vulnerable › Vulnerabilities

CVE-2025-1211

Description

Versions of the package hackney before 1.21.0 are vulnerable to Server-side Request Forgery (SSRF) due to improper parsing of URLs by URI built-in module and hackey. Given the URL http://127.0.0.1?@127.2.2.2/, the URI function will parse and see the host as 127.0.0.1 (which is correct), and hackney will refer the host as 127.2.2.2/. This vulnerability can be exploited when users rely on the URL function for host checking.

Affected products

How to fix

Upgrade to a fixed version: hackney 1.21.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-1211 or the next vulnerability affects your stack