What’s Vulnerable › Vulnerabilities
CVE-2025-1212: Exposure of Sensitive System Information to an Unauthorized Control Sphere in GitLab
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-12 · updated 2026-06-17
- Weakness: CWE-497
Description
An information disclosure vulnerability in GitLab CE/EE affecting all versions from 8.3 prior to 17.6.5, 17.7 prior to 17.7.4, and 17.8 prior to 17.8.2 allows an attacker to send a crafted request to a backend server to reveal sensitive information.
Affected products
- GitLab: from 8.3.0 before 17.6.5; from 17.7.0 before 17.7.4; from 17.8.0 before 17.8.2 — fixed in 17.6.5, 17.7.4, 17.8.2
How to fix
Upgrade to a fixed version: GitLab 17.6.5, 17.7.4, 17.8.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-1212 or the next vulnerability affects your stack