What’s Vulnerable › Vulnerabilities
CVE-2025-1215: vim main.c memory corruption
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-02-12 · updated 2026-06-17
- Weakness: CWE-119
Description
A vulnerability classified as problematic was found in vim up to 9.1.1096. This vulnerability affects unknown code of the file src/main.c. The manipulation of the argument --log leads to memory corruption. It is possible to launch the attack on the local host. Upgrading to version 9.1.1097 is able to address this issue. The patch is identified as c5654b84480822817bb7b69ebc97c174c91185e9. It is recommended to upgrade the affected component.
Affected products
- NetApp Bootstrap Os: all versions
- vim/vim: before 9.1.1097 — fixed in 9.1.1097
How to fix
Upgrade to a fixed version: vim/vim 9.1.1097. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/c5654b84480822817bb7b69ebc97c174c91185e9
- https://github.com/vim/vim/issues/16606
- https://github.com/vim/vim/releases/tag/v9.1.1097
- https://vuldb.com/?ctiid.295174
- https://vuldb.com/?id.295174
- https://vuldb.com/?submit.497546
- https://security.netapp.com/advisory/ntap-20250321-0005/
- https://github.com/vim/vim/issues/16606
- https://vuldb.com/?submit.497546
Get alerted when CVE-2025-1215 or the next vulnerability affects your stack