What’s Vulnerable › Vulnerabilities
CVE-2025-1218: Various packet overreads in mysqlnd_writeprotocol.c
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-09-25 · updated 2026-10-23
- Weakness: CWE-122
Description
The mysqlnd wire protocol parser reads fields out of server packets before checking that the packet still holds enough bytes for them. A malicious or compromised MySQL server can send a truncated packet and make the client read past the end of the packet buffer, which is undefined behaviour and can crash the process.
Affected products
- PHP: from 8.2.0 before 8.2.34; from 8.3.0 before 8.3.35; from 8.4.0 before 8.4.26; from 8.5.0 before 8.5.11 — fixed in 8.2.34, 8.3.35, 8.4.26, 8.5.11
How to fix
Upgrade to a fixed version: PHP 8.2.34, 8.3.35, 8.4.26, 8.5.11. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-1218 or the next vulnerability affects your stack