What’s Vulnerable › Vulnerabilities
CVE-2025-12414: Looker account compromise via punycode homograph attack
- Severity: critical (CVSS 9.2 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-20 · updated 2026-10-18
- Weakness: CWE-290
Description
An attacker could take over a Looker account in a Looker instance configured with OIDC authentication, due to email address string normalization.Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted. Self-hosted instances must be upgraded as soon as possible. This vulnerability has been patched in all supported versions of Self-hosted. The versions below have all been updated to protect from this vulnerability. You can download these versions at the Looker download page https://download.looker.com/ : * 24.12.100+ * 24.18.193+ * 25.0.69+ * 25.6.57+ * 25.8.39+ * 25.10.22+ * 25.12.0+
Affected products
- Google Cloud Looker: before 24.12.100; before 24.18.193; before 25.0.69; before 25.6.57; before 25.8.39; before 25.10.22 — fixed in 24.12.100, 24.18.193, 25.0.69, 25.10.22, 25.12.0, 25.6.57
How to fix
Upgrade to a fixed version: Google Cloud Looker 24.12.100, 24.18.193, 25.0.69, 25.10.22. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-12414 or the next vulnerability affects your stack