What’s Vulnerable › Vulnerabilities

CVE-2025-12419: Account takeover on OAuth/OpenID-enabled servers

Description

Mattermost versions 10.12.x <= 10.12.1, 10.11.x <= 10.11.4, 10.5.x <= 10.5.12, 11.0.x <= 11.0.3 fail to properly validate OAuth state tokens during OpenID Connect authentication which allows an authenticated attacker with team creation privileges to take over a user account via manipulation of authentication data during the OAuth completion flow. This requires email verification to be disabled (default: disabled), OAuth/OpenID Connect to be enabled, and the attacker to control two users in the SSO system with one of them never having logged into Mattermost.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.11.5, 10.12.2, 10.5.13, 11.0.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-12419 or the next vulnerability affects your stack