What’s Vulnerable › Vulnerabilities
CVE-2025-12421: Account Takeover via Code Exchange Endpoint
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-27 · updated 2026-10-19
- Weakness: CWE-303
Description
Mattermost versions 11.0.x <= 11.0.2, 10.12.x <= 10.12.1, 10.11.x <= 10.11.4, 10.5.x <= 10.5.12 fail to to verify that the token used during the code exchange originates from the same authentication flow, which allows an authenticated user to perform account takeover via a specially crafted email address used when switching authentication methods and sending a request to the /users/login/sso/code-exchange endpoint. The vulnerability requires ExperimentalEnableAuthenticationTransfer to be enabled (default: enabled) and RequireEmailVerification to be disabled (default: disabled).
Affected products
- Mattermost: from 10.5.0 before 10.5.13; from 10.11.0 before 10.11.5; from 10.12.0 before 10.12.2; from 11.0.0 before 11.0.3 — fixed in 10.11.5, 10.12.2, 10.5.13, 11.0.3
How to fix
Upgrade to a fixed version: Mattermost 10.11.5, 10.12.2, 10.5.13, 11.0.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-12421 or the next vulnerability affects your stack