What’s Vulnerable › Vulnerabilities
CVE-2025-12466: Simple OAuth (OAuth2) & OpenID Connect - Critical - Access bypass - SA-CONTRIB-2025-114
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-30 · updated 2026-10-08
- Weakness: CWE-288
Description
Authentication Bypass Using an Alternate Path or Channel vulnerability in Drupal Simple OAuth (OAuth2) & OpenID Connect allows Authentication Bypass.This issue affects Simple OAuth (OAuth2) & OpenID Connect: from 6.0.0 before 6.0.7.
Affected products
- Drupal Simple OAuth (OAuth2) & OpenID Connect: from 6.0.0 before 6.0.7 — fixed in 6.0.7
How to fix
Upgrade to a fixed version: Drupal Simple OAuth (OAuth2) & OpenID Connect 6.0.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-12466 or the next vulnerability affects your stack