What’s Vulnerable › Vulnerabilities
CVE-2025-12472: Remote Code Execution in Looker due to Improperly Validated Directory Deletion
- Severity: high (CVSS 7.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-19 · updated 2026-10-18
- Weakness: CWE-362
Description
An attacker with a Looker Developer role could manipulate a LookML project to exploit a race condition during Git directory deletion, leading to arbitrary command execution on the Looker instance. Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted instances. No user action is required for these. Self-hosted instances must be upgraded as soon as possible. This vulnerability has been patched in all supported versions of Self-hosted. The versions below have all been updated to protect from this vulnerability. You can download these versions at the Looker download page https://download.looker.com/ : * 24.12.103+ * 24.18.195+ * 25.0.72+ * 25.6.60+ * 25.8.42+ * 25.10.22+
Affected products
- Google Cloud Looker: before 24.12.103; before 24.18.195; before 25.0.72; before 25.6.60; before 25.8.42; before 25.10.22 — fixed in 24.12.103, 24.18.195, 25.0.72, 25.10.22, 25.6.60, 25.8.42
How to fix
Upgrade to a fixed version: Google Cloud Looker 24.12.103, 24.18.195, 25.0.72, 25.10.22. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-12472 or the next vulnerability affects your stack