What’s Vulnerable › Vulnerabilities
CVE-2025-12485
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-06 · updated 2026-10-07
- Weakness: CWE-269
Description
Improper privilege management during pre-MFA cookie handling in Devolutions Server allows a low-privileged authenticated user to impersonate another account by replaying the pre-MFA cookie.This does not bypass the target account MFA verification step. This issue affects the following versions : * Devolutions Server 2025.3.2.0 through 2025.3.5.0 * Devolutions Server 2025.2.15.0 and earlier
Affected products
- Devolutions Server: before 2025.2.17.0; from 2025.3.2.0 before 2025.3.6.0 — fixed in 2025.2.17.0, 2025.3.6.0
How to fix
Upgrade to a fixed version: Devolutions Server 2025.2.17.0, 2025.3.6.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-12485 or the next vulnerability affects your stack