What’s Vulnerable › Vulnerabilities
CVE-2025-12499: Rich Shortcodes for Google Reviews <= 6.8 - Unauthenticated Stored Cross-Site Scripting via Google Review
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-06 · updated 2026-10-15
- Weakness: CWE-79
Description
The Rich Shortcodes for Google Reviews plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the contents of a Google Review in all versions up to, and including, 6.8 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. NOTE: This vulnerability was partially patched in version 6.6.2.
Affected products
- widgetpack Rich Showcase for Google Reviews: through 6.8
References
- https://plugins.trac.wordpress.org/changeset/3389203/widget-google-reviews
- https://plugins.trac.wordpress.org/changeset/3411521/widget-google-reviews
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e2960224-4446-4fc6-8d18-6f9911b4cbad?source=cve
Get alerted when CVE-2025-12499 or the next vulnerability affects your stack