What’s Vulnerable › Vulnerabilities
CVE-2025-12511: A user with elevated privileges can inject XSS in the DSM Administration’s Extensions configuration page
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-05 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Centreon Infra Monitoring (DSM extenstio configuration modules) allows Stored XSS to user with elevated privileges. This issue affects Infra Monitoring: from 25.10.0 before 25.10.1, from 24.10.0 before 24.10.4, from 24.04.0 before 24.04.8.
Affected products
- Centreon Dynamic Service Management: from 24.04.0 before 24.04.8; from 24.10.0 before 24.10.4; 25.10.0 — fixed in 24.04.8, 24.10.4
How to fix
Upgrade to a fixed version: Centreon Dynamic Service Management 24.04.8, 24.10.4. Check the vendor advisory for mitigations.
References
- https://github.com/centreon/centreon/releases
- https://thewatch.centreon.com/latest-security-bulletins-64/cve-2025-12511-centreon-dsm-medium-severity-5361
Get alerted when CVE-2025-12511 or the next vulnerability affects your stack