What’s Vulnerable › Vulnerabilities
CVE-2025-1252: Heap-based Buffer Overflow vulnerability in RTI Connext Professional (Core Libraries) allows Overflow Variables and Tags.
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-08 · updated 2026-09-22
- Weakness: CWE-122
Description
Heap-based Buffer Overflow vulnerability in RTI Connext Professional (Core Libraries) allows Overflow Variables and Tags. This issue affects Connext Professional: from 7.4.0 before 7.5.0, from 7.0.0 before 7.3.0.7, from 6.1.0 before 6.1.2.23, from 6.0.0 before 6.0.1.42, from 5.3.0 before 5.3.*, from 5.2.0 before 5.2.*, from 4.4d before 5.1.*.
Affected products
- RTI Connext Professional: from 4.4 through 5.2.3; from 5.3.0 through 5.3.1.45; from 6.0.0 through 6.0.1.40; from 6.1.0 before 6.1.2.23; from 7.0.0 before 7.3.0.7; from 7.4.0 before 7.5.0 — fixed in 6.1.2.23, 7.3.0.7, 7.5.0
How to fix
Upgrade to a fixed version: RTI Connext Professional 6.1.2.23, 7.3.0.7, 7.5.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-1252 or the next vulnerability affects your stack