What’s Vulnerable › Vulnerabilities
CVE-2025-1255: Untrusted Pointer Dereference vulnerability in RTI Connext Professional (Core Libraries) allows Pointer Manipulation.
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-23 · updated 2026-10-11
- Weakness: CWE-822
Description
Untrusted Pointer Dereference vulnerability in RTI Connext Professional (Core Libraries) allows Pointer Manipulation. This issue affects Connext Professional: from 7.4.0 before 7.6.0, from 7.2.0 before 7.3.0.9.
Affected products
- RTI Connext Professional: from 7.2.0 before 7.3.0.9; from 7.4.0 before 7.6.0 — fixed in 7.3.0.9, 7.6.0
How to fix
Upgrade to a fixed version: RTI Connext Professional 7.3.0.9, 7.6.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-1255 or the next vulnerability affects your stack