What’s Vulnerable › Vulnerabilities

CVE-2025-12555: Incorrect Authorization in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 15.1 before 18.7.6, 18.8 before 18.8.6, and 18.9 before 18.9.2 that, under certain conditions, could have allowed an authenticated user to access previous pipeline job information on projects with repository and CI/CD disabled due to improper authorization checks.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.7.6, 18.8.6, 18.9.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-12555 or the next vulnerability affects your stack