What’s Vulnerable › Vulnerabilities

CVE-2025-12562: Allocation of Resources Without Limits or Throttling in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 11.10 before 18.4.6, 18.5 before 18.5.4, and 18.6 before 18.6.2 that could have allowed an unauthenticated user to create a denial of service condition by sending crafted GraphQL queries that bypass query complexity limits.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.4.6, 18.5.4, 18.6.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-12562 or the next vulnerability affects your stack