What’s Vulnerable › Vulnerabilities

CVE-2025-1257: Allocation of Resources Without Limits or Throttling in GitLab

Description

An issue was discovered in GitLab EE affecting all versions starting with 12.3 before 17.7.7, 17.8 prior to 17.8.5, and 17.9 prior to 17.9.2. A vulnerability in certain GitLab instances could allow an attacker to cause a denial of service condition by manipulating specific API inputs.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.7.7, 17.8.5, 17.9.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-1257 or the next vulnerability affects your stack