What’s Vulnerable › Vulnerabilities

CVE-2025-12571: Allocation of Resources Without Limits or Throttling in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 17.10 before 18.4.5, 18.5 before 18.5.3, and 18.6 before 18.6.1 that could have allowed an unauthenticated user to cause a Denial of Service condition by sending specifically crafted requests containing malicious JSON payloads.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.4.5, 18.5.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-12571 or the next vulnerability affects your stack