What’s Vulnerable › Vulnerabilities
CVE-2025-12613
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-10 · updated 2026-10-19
- Weakness: CWE-88
Description
Versions of the package cloudinary before 2.7.0 are vulnerable to Arbitrary Argument Injection due to improper parsing of parameter values containing an ampersand. An attacker can inject additional, unintended parameters. This could lead to a variety of malicious outcomes, such as bypassing security checks, altering data, or manipulating the application's behavior. **Note:** Following our established security policy, we attempted to contact the maintainer regarding this vulnerability, but haven't received a response.
Affected products
- cloudinary: before 2.7.0 — fixed in 2.7.0
How to fix
Upgrade to a fixed version: cloudinary 2.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/cloudinary/cloudinary_npm/commit/ec4b65f2b3461365c569198ed6d2cfa61cca4050
- https://github.com/cloudinary/cloudinary_npm/pull/709
- https://security.snyk.io/vuln/SNYK-JS-CLOUDINARY-10495740
Get alerted when CVE-2025-12613 or the next vulnerability affects your stack