What’s Vulnerable › Vulnerabilities
CVE-2025-12628: WP 2FA < 3.0.0 - Second Factor Bypass
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-24 · updated 2026-10-08
Description
The WP 2FA WordPress plugin does not generate backup codes with enough entropy, which could allow attackers to bypass the second factor by brute forcing them
Affected products
- WP 2FA: before 3.0.0 — fixed in 3.0.0
How to fix
Upgrade to a fixed version: WP 2FA 3.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-12628 or the next vulnerability affects your stack